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Notes for the reader 

How to use this manual 

This manual provides advices and information’s about the function and configuration of the Mas-
terPort 2 PSU.  

 

Like all devices of LSS GmbH the MasterPort 2 PSU is constantly evolving technology. It is therefore 
possible that this manual does not explain later development forms. 

 

This manual uses the following symbols to indicate important information for your safety and for 
configuration. 

 

Here you will get additional information.  

 

 

Attention alerts you to situations in which decisions can provoke to technical prob-
lems with the equipment or losing data. 

 

 

A Warning statement indicates situations in which can result in injury or damage to 
life and limb. 

 

 

Safety advices 

Proper care of the MasterPort 2 PSU is not dangerous. However please note the following 

 

 Authorized personnel must install the device! 

 Never operate with visibly damaged devices! 

  If the suspect prior to a defect, immediately disconnect the device from the power 
supply! Secure the device to restart! 

 Disconnect the device from the power supply before you open the case! 

 Employees of the LSS GmbH may only make repairs! 
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Instruction for use 

The MasterPort 2 PSU is designed for continuous operation.  However please note the following: 

 

 Use the device only for its intended purpose! 

 Avoid extreme mechanical loads! 

  Avoid extreme mechanical loads on the display! 

 To clean the display, turn off the power! Use a damp cloth only. 

 Avoid direct exposure to moisture and excessive heat on the device! 

 Do not cover the ventilation openings! Risk of fire! 

 Don’t mount the unit directly above headlights! 
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The MasterPort 2 PSU 
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General Overview 

 

The MasterPort 2 PSU is the successor to the popular MasterPort PSU, which can be found in many 
lighting systems in Europe. In the second generation LLS extended significantly the capabilities of 
the node for lighting networks with the ability to act as voltage supplier for devices in the lighting 
system. In addition to the new, even more powerful CPUs the new Power-DMX outputs are strik-
ing. 

 

As usual with the MasterPort 2 PSU is a converter of Ethernet data in up to four DMX universes. In 
each Universe up to four channels can be merged on the principle of HTP. MasterPort 2 PSU split 
these universes in two DMX-Out ports: The upper DMX-Port is just a 5pin XLR data output. But the 
lower DMX-Port is a 4pin XLR data plus power supply output! So each universe can be output in 
two DMX-Out ports simultaneously: Either a pure data universe or as a data-power universe. All 
DMX ports are RDM ready to ANSI E1.20 2006. 

 

The PSU ports powered end devices, such as colour changers, motor brackets and LED luminaires 
by 24 volts and up to 5 amps per channel. The maximum current of each DMX port is adjustable in 
steps of 0,1 ampere and a constant current and voltage measurement monitors the output power 
up to self-shutdown of the corresponding DMX channel. 

 

The new CPU enables faster protocol conversions from Ethernet to DMX. As before the protocols 
Art-Net, sACN, AVAB / IPX, AVAB / UDP, ShowNet are supported. In addition, now the MasterPort 
2 PSU supports Art-Net3. 

 

Like many other devices of LSS also, the MasterPport 2 PSU is designed explicitly for use close to 
the stage. This means that it is passively cooled and therefore totally silent, the display configura-
tion can be switched off and, not least, the LSS MasterPort 2 PSU can be completely configured 
remotely by the software LSS ConfigCore. 
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Supported Protocols 

The LSS MasterPort 2 PSU supports the following protocols: 

 

 Art-Net  ShowNet 

 AVAB/UDP  AVAB/IPX 

 sACN  DMX512 

 

Connectors 

 

Ethernet:  1x RJ45, 100MBit 

 

DMX:   4x DMX-Out 5pin XLR 

   4x Power-DMX-Out 4 pin XLR 

   All DMX-Outs are electrical isolated 
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Functional overview 

DMX 

DMX Outputs 

 

 

Common to all DMX outputs the following parameters can be set: 

 Response to reception loss of all sources (power off, hold, send zeros) 

 Break length 90 ... 999 ĩS 

 Mark After Break 20 ... 999 ĩS 

 

So the MasterPort 2 PSU is adjustable to each component. 

 

 

The MasterPort 2 PSU can only be used as a protocol converter between DMX and 
Ethernet-based network protocols. For conversions of Ethernet to Ethernet a LSS Mas-
terGate must be used! 

 

 

Ethernet 

Data transfer rate 

The MasterPort 2 PSU is characterized by high throughput and low latency (delay) in both direc-
tions. The Ethernet interface supports up to 100MBit/s and the internal CPU runs on a very fast 
real-time multitasking operating system. So a maximum throughput of more than 1000 network 
packets per second is possible. 

 

 

Ethernet protocols 

The default Ethernet protocol of the MasterPort 2 PSU at delivery is the non-proprietary Art-Net of 
ArtisticLicence. The current protocol version is 1.4bd III. 
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Remote configuration 

For all devices of LSS the freeware LSS ConfigCore is recommended. All features of the MasterPort 
2 PSU and other LSS devices, but also Art-Net compatible devices of other manufacturers will be 
supported. Only with this freeware it is possible to find all devices on the network and configure 
the MasterPort 2 PSU fully remotely. 

 

Because the MasterPort 2 PSU is an Art-Net compatible device itself so it works fine with Art-Net 
software tools of other manufacturers, especially DMX Workshop (download at 
www.artisticlicence.com). Of course, like all other Art-Net devices the MasterPort 2 PSU has an 
own OEM ID (identified and supported by DMX Workshop version 3.57 and higher). Using this tool, 
also a restricted remote configuration is possible. By using DMX Workshop note Art-Net can only 
configure a subset of the MasterPort 2 PSU. 

 

 

If other protocols than Artet will be set the MasterPort 2 PSU will be always configura-
ble with ConfigCore. Providing that the PC with ConfigCore is in the same IP address 
range like the MasterPort 2 PSU. 

 

Parameters 

For all lighting protocols, you can set the following parameters: 

 Minimum transmission rate without change of values: 20 ms ... 4s 

 Timeout 1 … 999 s (Hold etc. is set per DMX-Out) 

 Timeout is adjustable globally only, but each subnet/Universe is checked individually  

 

IP parameters 

For all TCP/IP based protocols you can still define the following parameters: 

 IP address manually / Art-Net 2.xxx / Art-Net 10.xxx / DHCP 

 IP subnet mask 

 Gateway IP 

 

Merge settings 

The MasterPort 2 PSU is able to merge up to four channels on HTP when they send on the same 
subnet / universe. This distinguishes this device from most of other nodes. For instance Art-Net 
supports one or two transmitters only. 

 

Priorities are supported, if permitted by the lighting protocol. But proprietary extensions, such as 
“Priorities per circle”, will be not supported.  
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Screens and Configuration 
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Device overview 

At the front side of the LSS MasterPort 2 PSU the DMX-Ports and area of configuration are situat-
ed.  

 

 

 

 

Operation LED 

 

 

Menu settings 

 

 

 

DMX-Out 

 

 

 

Power 

DMX-Out 

 

 

 

 

 

 

Connectors 

The connectors of the LSS MasterPort 2 PSU are located directly on the device. All DMX ports are 
disposed on the front side. The RJ45 connector and the connectors for external power supply are 
on the rear. 

 

The DMX ports and their associated Power-DMX ports represent one universe in two parallel-
connected ports. So its possible to use the pure DMX data port and the Power-DMX port simulta-
neously to operate as one universe. 
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Operation LED 

The LEDs on the front panel displays the operating status of the MasterPort 2 PSU. 

 

LED Colour Meaning 

Power Blue On: Operation voltage available 

Off: Operation voltage is not available 

LINK/DATA Yellow On: Ethernet-LINK enabled, no Data 

Flash: Ethernet-LINK enabled, running Data transfer 

Off: Ethernet-LINK is not enabled 

ACTIVE/FAIL  Green 
 
 
 
 
 
 
Red 
 

DMX display for all DMX ports 
On: At least one DMX port is running 
Blink: At least one port has no data and HOLD last received data 
Flash: At least one port has no data and sends ZERO 
Out: All ports are turned off 
 
 
Displays error messages 
Blink:  Software error. Inform service! 
On: Combined error. Inform service! 

 

Inside the device, further diagnostic LEDs are provided. These are intended for service and 
maintenance. 

 

PSU LEDs  

The LEDs to display the status of the PSUs are located above the power DMX connectors 

 

LED Colour Meaning 

PSU Power Green On: Operating voltage available  

Flash: Not operating voltage available 

PSU Over-
load 

Red On: Required operating voltage is too high 

Off: Required operating voltage within set parameters 
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Menu settings 

The configuration of the MasterPort 2 PSU on the device occurs via a convenient menu system. 
The menu is displayed on a brilliant blue-white 20x4 LCD display with energy-saving LED backlit 
and a long life. If the screen saver is used the life of the display is further increased by a multiple. 

 

The individual menu items are selected und set by using a rotary / push encoder. 

 

 

 

 

 

 

Menu screen 

 

 

 

 

 

Rotary/push encoder 

 

  Use the screen saver! This increases the life of the display by a multiple. 

 

You can adjust the contrast of the display in the menu. Readjustment is usually not neces-
sary, because the display is already temperature compensated. 

 

 

Power supply control unit 

The power supply of the control unit can be realized either via Power-over-Ethernet (PoE) or with 
an external power supply. In the PoE version the power supply is ensured by endspan devices (eg 
directly PoE-capable switches) or midspan devices (devices between switch and end device). 

 

Is the MasterPort 2 PSU connected to a PoE-capable device and to an external power supply, the 
priority is given to PoE. 
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Power Supply Unit (PSU) 

The MasterPort 2 PSU can supply DMX controlled devices in addition to data also with the neces-
sary voltage. For this each PSU ports transmit a voltage of 24V with a current up to 5A. For each 
channel, the output current can be set in 0.1A steps. The MasterPort 2 PSU constantly monitors 
these currents and switched off in case of overload the corresponding port. 

 

With a separate DMX addressing for each port the MasterPort 2 PSU is also able to switch on the 
ports. This is very simple with a signal from the lighting console. 

 

The Power Supply Unit is continuously temperature monitored. Warning and shutdown tempera-
tures are set in the system. They can be changed by LSS only. If the warning temperature is 
reached, a warning message appears on the screen. If the shutdown temperature is reached, the 
Power-DMX ports switched off automatically. Another message appears on the screen. The Pow-
er-DMX ports remain off until the temperature of the Power Supply Unit is 10° C less than the 
warning temperature. The shutdown can not be manually stopped or bypassed. 
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Configuration of the MasterPort 2 
PSU 
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Instructions for the configuration 

Design and selection 

The menu structure of the MasterPort 2 PSU is arranged hierarchically. It started with the First 
Level, from which the access is made to the main menu. From the main menu, the other submen-
us are divided thematically into levels.  

 

Menu selection 

Turning the rotary / push encoder selects the various menu submenus and settings by a wandering 
►. A quick push on the encoder opens this submenu or confirms the setting. 

 

Changing settings 

The selected parameter is shown with an inverse flashing first character and can now be changed 
by turning the encoder. Pressing it again takes on the setting. Changed parameters are active im-
mediately. 

 

Confirming the "◄" the Master Port 2 PSU controller return to the parent menu. Before the menu 
is displayed, you will be asked if you want to save the changed parameters. 

 

Save settings 

To save the set parameters confirm the request with "Yes". The modified parameters are stored 
permanently. With "No" you will return to the parent menu, set parameters will not saved, even 
though they had already been suspended temporarily. 

 

Is the encoder in an adjustable period not used, the First Level will be activated. Simultaneously 
the access of the device will be locked and the typed password will be deleted to prevent unau-
thorized manipulation. Any unsaved changes of parameters in the currently open menu will be 
lost! 
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Legend for the scheme of the menu 

The structure of the menu and the configuration options are described below schematically. The 
used symbols have the following meanings: 

 

Symbol Meaning 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Display 

 

Menu name 

 

 

 

 

 

 

Shows settable parameters  

 

 

 

 Rotate encoder to select 

 Push the Encoder 

 Shows the menu path 
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First Level 

The First Level of the menu of the MasterPort 2 PSU scrolls through different diagnostic pages. 
These pages give a quick overview of different settings and the operating status of the device. 

 

A rotation of the encoder interrupts the automatic scroll. Further rotations display the diagnostic 
pages manually. The automatic scroll is displayed by means of a flashing  icon top right. The icon 
changes in II when switching to manual scroll. 

 

It is possible to replace the First Level by other displays. Further information are on menu Options. 
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Main menu 

PIN request 

All submenus, such as display, configuration and other settings menus, are accessed from the main 
menu. If a PIN has been assigned, it will be requested before the main menu appears: 

 

 
 

Using the encoder enters the PIN-code input. For safety appears before and after scrolling [*****] 
will be displayed only. 

 

Structure of the main menu  

All submenus will be accessed from the main menu. To access the main menu from the First Level 
push the encoder for one second. 

 

 
 

Submenu Meaning 

View Network and DMX monitors 

Config Configuration of the MasterPort 2 PSU 

Options Configuration of optional settings 

◄ Back to First Level 
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View menu 

The displays in the View Menu will give you an overview of the current state of the MasterPort 2 
PSU. Current events, data-in-and output and the merge behaviour are presented. The displays in 
the View Menu are in real time. So they can be used easily as a monitoring and diagnostic tool. 

 

Structure of the view menu 
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View→DMX 

This monitor provides an overview of the activities in the DMX ports. The submenus for all ports 
and the signals for each bit are represented in hexadecimal or percentage. 

 

Submenu Meaning 

DMX 1…4 DMX-Port 1…4 

IN The icon is only available, when DMX-In ports are equipped. 

Full:   On the DMX-In a correct DMX protocol is received 

E:   DMX protocol on the input is invalid (start code or timing) 

Empty:  No signal on the DMX input 

OUT The icon is only available, when DMX-Out ports are equipped. 

Full:   At the DMX-Out a signal with DMX protocol is sent 

H:   DMX-Out is on HOLD and holds the last data 

Z:   DMX-Out is on HOLD and sends zero values 

Empty:  DMX-Out is switched off 

Cnt Displays the number of packets sent per second. 

F Displays the frame rate per second. 

► Calls up submenu 

◄ Return to parent menu 
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View→Network 

View→Network→Monitor 

 

This monitor displays the current settings of the DMX ports. 

 

Selection Meaning 

1…4 DMX Port 1…4 

Act Full: on this subnet/universe combination light data will be received 

Empty: on this subnet/universe combination are no light data 

Sub Logical subnet (depends on the used protocol) 

A “-“ is displayed if the DMX-Port is disabled in the routing menu or the 
used protocol has no subnets.  

Uni Universe (depends on the used protocol) 

A “-“ is displayed if the DMX-Port is disabled in the routing menu or the 
used protocol has no univeres. 

► Calls up submenu 

◄ Return to parent menu 

 

 

View→Network→Counter 

This submenu shows monitors that provide an overview of incoming and outgoing data and data 
packets. The monitors display very comprehensive information. This information can be used for 
network diagnostics. 

 

Selection Meaning 

In Calls up received data network counter 

Out Calls up sent data network counter 

Data Calls up data packets counter 

► Calls up counter 

◄ Return to parent menu 
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View→Network→Counter→In/Out 

 

Selection Meaning 

kByte Total received kByte 

Packets Total received packets 

Errors Total RX error 

Dropped Total dropped packets 

Overrun (In only) Total overrun 

Aborted (Out only) Total aborted packets 

Length (In only) Total length error 

Carrier (Out only) Total lost carrier 

CRC (In only) Total CRC errors  

Heartbt (Out only) Total lost Ethernet heartbeat  

Frame Total frame errors 

FIFO Total FIFO overflow 

Diff0 Counter the loss of packets in the network 

Diff1 Counter the loss of packets in the network 

Diff2 Counter the loss of packets in the network 

Diff3 Counter the loss of packets in the network 

◄ Return to parent menu 

 
 

View→Network→Counter→Data 

 

Selection Meaning 

Rx Received data volumes 

Tx Sent data volumes 

Pack./s Packets per second 

kByte Amount of data in kByte 

◄ Return to parent menu 
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View→PSU 

This submenu shows monitors that provide an overview of current and voltage supply to the PSU 
ports. Each PSU port has its own monitor. 
 

Selection Meaning 

Port 1 Calls up monitor PSU port 1 

Port 2 Calls up monitor PSU port 2 

Port 3 Calls up monitor PSU port 3 

Port 4 Calls up monitor PSU port 4 

► Calls up monitor 

◄ Return to parent menu 

 

View→PSU→Port x 

Selection Meaning 

Line 2 

x.x V (left) Shows PSU input voltage 

x.x V (centre) Shows voltage at PSU port 

x.x A Shows load current  

x.x A! Shows load current approaches set switch threshold 

Line 3 

Mode Shows the set action when switch threshold is reached 

On/Off (right) Shows the current switching state of the PSU port 

Line 4 (following indicators never occur simultaneously) 

No load There are no loads. All voltages within the parameters.  

Normal load A load is connected to the PSU port. The PSU port operates within the set 
and allowed parameters. 

24V supply failure 24V PSU power supply is not available. 

24V out of range! The outgoing PSU voltage is out of the factory parameters. Check power 
supply! 

24V from outside! Energetic recovery! Check connection! The device may be destroyed! 

Current Overload The PSU-port has been automatically disabled. The load current was ei-
ther higher than the switch threshold or higher than 5A. 

Short / Overtemp! The PSU-port has been automatically disabled. A short circuit is present, 
or a temperature above the safety parameters were measured. 

◄ Return to parent menu 
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Configuration menu 

The range of setting options of the MasterPort 2 PSU can be changed easily in the configuration 
menu. Any change in the configuration needs to be confirmed. This is for your safety and that of 
the equipment. 

 

Please note: 

Any change in the settings can have far-reaching consequences for your lighting sys-
tem. The following descriptions of the configuration options require that you have ex-
perience and knowledge in the configuration of DMX and Ethernet protocols. 

 

Structure of the Configuration menu 

 

 
 

Submenu Setting options 

Routing Merge settings 

DMX DMX settings 

Network Ethernet settings 

PSU PSU settings 

► Calls up submenu 

◄ Return to parent menu 
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Config→Routing 

In the submenu “Routing” the merge settings will be set and the DMX ports assigned to the Ether-
net subnets and universes. 

 

 

 
 

Selection Meaning 

Port 1 Settings for Port 1 

Port 2 Settings for Port 2 

Port 3 Settings for Port 3 

Port 4 Settings for Port 4 

► Calls up submenu 

◄ Return to parent menu 
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Selection Meaning 

Mode Off: Ethernet will not receive. DMX-Out is disabled.  

 

Single:  

The first active data source is used until it fails with a time out. Then the 
data of another active source on the same subnet and universe are used. 

The data-source detection in place for 

- AVAB / IPX by direct evaluation of the MAC address 

- sACN by the device ID 

- All other protocols through the IP address of the data source. This must 
be specific to each data source. 

 

Merge4: 

Data from up to four data sources can be merged (HTP - Highest Takes 
Precedence). If more than four sources transmit on the same subnet and 
universe, the data of the source(s) coming up after the first four will be 
ignored. If one of the first four data sources fails, automatically advances 
the data source from the ignored, which first sends data after the failure 
(principle “First come, first serve”). 

Universe Setting of the sending universe (depends on the protocol) 

Subnet Setting of the sending subnet (depends on the protocol) 

► Change settings 

◄ Return to parent menu / Save settings 

 

 

For protocols with priorities are the following features: 

Protocol Priority treatment 

AVAB/UDP Priority 1 ... 200: The data source with the highest priority value wins. 

Several data sources with the same highest priority are merged (HTP). 

Data sources that send 0 will always be merged (HTP) with data source(s) 
with the highest priority. 

sACN Priority 1 ... 200: The data source with the highest priority value wins. 

Several data sources with the same highest priority are merged (HTP). 

Data sources that send 0 are treated as priority 100 
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Config→DMX 

This submenu sets the following settings: 

- Behaviour of DMX ports in case of data reception loss 

- Setting the timings for the DMX transmission (Mark-after-break, etc.) 

 

 

 
 

Selection Meaning 

Failure In case of data reception loss: 

Off:  The DMX port will be disabled. 

Hold:  Last received value will be hold and transmitted unchanged 

Zero:   Data packets with the value "0" are transmitted 

Break Setting the break length of 90 to 999µs 

MAB Setting the Mark-after-Break length of 20 to 999µs 

► Change settings 

◄ Return to parent menu / Save settings 
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Config→Network 

In the submenu “Network” all protocols based on Ethernet will be set: 
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Selection Meaning 

Rx Prot Setting the receiving data protocol: 

 Art-Net  ShowNet 

 AVAB/IPX  sACN 

 AVAB/UDP  
 

Rx Tmo Setting the timeout for receiving data 1 to 999s 

Tx Prot Setting the transmission data protocol: 

 Art-Net  ShowNet 

 AVAB/IPX  sACN 

 AVAB/UDP  
 

Tx Rate Setting the minimum transmission rate for data packets, if there is no changing of 
the values:  20ms, 40ms, 80ms, 100ms, 200ms, 500ms, 1s, 2s, 3s, 4s 

IP Mode Getting the IP address: 

Manual:  Free adjustment 

Art-Net 2:  Art-Net address for 2 network 

Art-Net 10:  Art-Net address for 10 network 

DHCP:   If a DHCP server is on the network 

IP IP address   Manual adjustment is possible when "IP Mode = Manual" 

SN Netmask  Manual adjustment is possible when "IP Mode = Manual" 

GW Gateway  Usually changing the preset address is not necessary. 

Name Setting the Art-Net short name for naming the MasterPort 2 PSU, eg Location "back-
stage" 

sACN 
Draft 

Setting the supported version of sACN 

Off   MasterPort 2 PSU sends sACN according to E1.31 2009 

On   MasterPort 2 PSU sendet sACN according to E1.31 R0 Draft 

Art-Net 
BC 

Art-Net is sent as broadcast. Its necessary for the control of ADB systems. 

Art-
Net3Nw 

Setting the IP address Art-Net3–networks.   

0:   Art-Net3 is disabled. 

1 to 127:  Art-Net3 is active and the number indicates the IP address. 
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Selection Meaning 

UDPChksm Setting to calculate the checksum of UDP packets 

Rx & Tx  Enables checksum for received and transmitted packets 

Rx only   Enables checksum for received packets only 

Tx only   Enables checksum for transmitted packets only 

Off   Disabled checksum 

EthMedia Setting the transmission rate 

Autoneg.  Enables automatic detection of transmission rate  

   (Autonegotiation) 

10 Half   Enables 10MBit/s Half Duplex 

10 Full   Enables 10MBit/s Full Duplex 

100 Half  Enables 100MBit/s Half Duplex 

100 Full  Enables 100MBit/s Full Duplex 

► Change settings 

◄ Return to parent menu / Save settings 
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Config→PSU 

All four PSU ports are constantly current and voltage monitoring. In this menu you can adjust the 
following settings: 

 The switching behaviour of each DMX port 

 The switching threshold for the switching behaviour 

 The DMX address to control each port  

 

 

 
 

Selection Meaning 

Port 1 Settings of PSU-Port 1 

Port 2 Settings of PSU-Port 2 

Port 3 Settings of PSU-Port 3 

Port 4 Settings of PSU-Port 4 

► Calls up submenu 

◄ Return to parent menu 
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Config→PSU→Port x 

 

Selection Meaning 

Switch Setting the switching behaviour 

On:  Service mode! Do not use in normal operation! 

Sense:  The Power-DMX port is automatically switched off when  
  the set current limit or the maximum current of 5A is  
  exceeded. The manual adjustment of the limit is set in the 
  submenu MaxCurr. 

DMX:  Here the DMX address is set. Via this address the   
  Power-DMX port is controlled. Current monitoring is active 
  and corresponds to the settings of "Sense". 

Off:  The Power-DMX port is disabled manually. 

MaxCurr Setting of the threshold for the current monitoring. This is set in incre-
ments of 0,1 A. 

DMX Channel Setting the DMX address for the control of the Power-DMX port. 

► Change settings 

◄ Return to parent menu / Save settings 

 
 
 

Never use the switch setting "ON" in continuous operation! This setting is for ser-
vice purposes only! A continuous load of more than 5A may destroy the MasterPort 
2 PSU and the entire lighting system! 

 
 
 

Reset the current monitor locally on the device 
Is the Power DMX port automatically switched off because the set switching 
threshold is exceeded, the device must be reset manually. The reset is initiated in 
the sub-menu "Options → Reset". All settings are retained. 
 
 
 
Reset the current monitor remotely when a DMX address for the port was set 
Is the Power-DMX port automatically switched off because the set switching 
threshold is exceeded, the port can reset remotly. Providing that a DMX address for 
the port was set, the port must switched off and on again remotly. All settings are 
retained. 
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Options 

In this menu additional settings of the MasterPort 2 PSU will be set.  

 

 

Structure of the Options menu 

 

 

 
 

Selection Meaning 

Display Screen and displaying settings 

Security Access and remote settings  

Default Restore factory settings 

Reset Restart CPU manually 

► Calls up submenu 

◄ Return to parent menu  
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Options→Display 

The settings for the screen and displays will be set in this submenu. 
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Selection Meaning 

Contrast Setting the contrast 

MenuTimeout Timeout setting for the return to the First Level, when the encoder is not 
used.  

(OFF, 15s, 30s, 1m, 3m, 5m, 10m, 15m, 20m, 30m, 45m, 1h, 2h, 3h, 4h, 6h, 8h, 
12h, 24h) 

ScreenSaver Timeout setting for the screensaver. After the set time the screensaver turns 
off the screen. This measure increases the lifetime of the display siginificantly. 
Inputs by the encoder or by remote control and events turn on the screen.  

(OFF, 15s, 30s, 1m, 3m, 5m, 10m, 15m, 20m, 30m, 45m, 1h, 2h, 3h, 4h, 6h, 8h, 
12h, 24h) 

Events Changes to the DMX or Ethernet can trigger events, which can be automatical-
ly displayed on the screen. This can lead to disruptive effects of light. 

On:  Changes turn on the screen und will be displayed  

Off:  Changes have no effect on the screen 

Debug On:  Turn on the debugger 

Off:  Turn off the debugger 

Default Replaces the display First Level by following options: 

Scroll:  “First Level” scrolls through diagnostic pages 

UserTxt: Displaying a user-specified text. When activated, below the line
  a new input mask for text input is displayed. 

FixScreen: A specific diagnostic page from the "First Level" is displayed 
  permanently. When enabled, the row below a selection of the 
  diagnostic pages will appear. 

  1: Serial – shows device and software details 

  2:  Counters – shows different counters and measured data 

  3: NW-Info – shows Ethernet details 

  4: N-In – Overview of receiving Ethernet data 

  5: DMX – Overview of transmitted DMX data 

  6: PSU-State – Shows output voltage and current per port 

► Change settings 

◄ Return to parent menu / Save settings 
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Structure of Options submenues 

 

 
 

Options→Security 

In this menu the security setting will be set. 

Selection Meaning 

Pin PIN for access main menu 

0…30000s (0 = off) 

Remote On: Access by remote is possible 

Off: Access by remote is not possible 

► Change settings 

◄ Return to parent menu / Save settings 

 

The system offers a range of 30,000 possible pins. But absolute security cannot be 
guaranteed! To prevent unauthorized access, additional specific safety measures 
must be taken. 
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Options→Factory Defaults  

All settings of the MasterPort 2 PSU can be restored to the factory settings. To prevent data loss, 
you have to confirm the security request twice. 

 

Selection Meaning 

No Restore abort 

Yes Restore the factory setting of the last firmware update 

► Change settings 

◄ Return to parent menu / Save settings 

 

 

 

Options→Reset 

By selecting a CPU reset is triggered. After the reset the previous saved settings are loaded. 

 

If you change the following settings in the configuration, the CPU will automatically reset: 

 Receiving protocol  Transmission protocol 

 IP mode  IP address 

 Netmask  Gateway 

 Restore factory defaults  
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Configuration with LSS ConfigCore 
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Configuration software ConfigCore 

The configuration of the LSS Master Port 2 PSU can also be done via the configuration software LSS 
ConfigCore. ConfigCore is a freeware and available on the homepage of LSS. ConfigCore only sup-
ports Microsoft Windows. 

 

To configure a MasterPort with 2 PSU ConfigCore, two preconditions must be fulfilled: 

 ConfigCore must be installed on a PC 

 The PC and the MasterPort 2 PSU must be in the same range of IP addresses and the same 
subnet 

 

Connecting the MasterPort 2 PSU with ConfigCore 

ConfigCore recognizes the MasterPort 2 PSU immediately when it is in the same subnet 

 

 

 

 

Devices 

 

 

 

 

Settings 

 

 

 

 

Devices area 

All devices found by ConfigCore are listed in this area. LSS devices have a “+” icon in the beginning 
of the IP address. Clicking this icon will open a menu tree. This allows access to special settings.  

 

Setting area 

All settings of the selected device are displayed here. 
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Status area 

In this area the following information will be displayed: 

 Reception protocol 

 Remote IP 

 Master address 

 Number of devices 

 Number of devices in data exchenage 

 

 

 

 

 

 

 

 

Status 
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ConfigCore menus  

Clicking the “+” icon calls up a menu tree. In the menu tree the submenus are coloured red. In the 
setting area depending on the selected menu various settings are displayed. 

 

Main menu 

The main menu gives an overview of the basic properties. Greyed entries are information only. 
The Art-Net short and long names can be changed only. To change the name the relevant name 
line must be selected. Enter the new description. To apply the changes use the button “Update”.  
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Advanced LSS Device Features 

Das Untermenü "Advanced LSS Device Features" beinhaltet alle Konfigurationsparameter, die auch 
aus dem internen Menü des MasterPort 2 PSU bekannt sind. 

 

 
 

 

Routing 

The submenu Routing corresponds to the device menu Config → Routing. Here the DMX ports are 
turned on and assigned to the Ethernet subnets and Universes. Also here the merging settings are 
set. 
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DMX-Out 

The DMX port is active when the MasterPort 2 PSU receives at least one data source on the set 
Subnet / Universe via Ethernet. Up to four data sources can be merged HTP. 

 

 
 

Selection Meaning 

Ethernet merge Off: Ethernet will not receive. DMX-Out is disabled.  

 

Single:  

The first active data source is used until it fails with a time out. Then the 
data of another active source on the same subnet and universe are used. 

The data-source detection in place for 

- AVAB / IPX by direct evaluation of the MAC address 

- sACN by the device ID 

- All other protocols through the IP address of the data source. This must 
be specific to each data source. 

 

Merge4: 

Data from up to four data sources can be merged (HTP - Highest Takes 
Precedence). If more than four sources transmit on the same subnet and 
universe, the data of the source(s) coming up after the first four will be 
ignored. If one of the first four data sources fails, automatically advances 
the data source from the ignored, which first sends data after the failure 
(principle “First come, first serve”). 

Universe Setting of the sending universe (depends on the protocol) 

Subnet Setting of the sending subnet (depends on the protocol) 
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For protocols with priorities are the following features: 

Protocol Priority treatment 

AVAB/UDP Priority 1 ... 200: The data source with the highest priority value wins. 

Several data sources with the same highest priority are merged (HTP). 

Data sources that send 0 will always be merged (HTP) with data source(s) 
with the highest priority. 

sACN Priority 1 ... 200: The data source with the highest priority value wins. 

Several data sources with the same highest priority are merged (HTP). 

Data sources that send 0 are treated as priority 100 

 
 

DMX 

The submenu DMX corresponds to the device menu Config → DMX. This submenu sets the follow-
ing settings: 

 Behaviour of DMX ports in case of data reception loss 

 Setting the timings for the DMX transmission (Mark-after-break, etc.) 

 

 
 

Selection Meaning 

Break Setting the break length of 90 to 999µs 

MAB Setting the Mark-after-Break length of 20 to 999µs 

DMX output behav-
iour 

In case of data reception loss: 

Off:  The DMX port will be disabled. 

Hold:  Last received value will be hold and transmitted unchanged 

Zero:   Data packets with the value "0" are transmitted 
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Ethernet 

The submenu Ethernet corresponds to the device menu Config → Network. This submenu sets the 
following settings: 

 
 

Selection Meaning 

Receive protocol Setting the receiving data protocol: 

 Art-Net  ShowNet 

 AVAB/IPX  sACN 

 AVAB/UDP  
 

Send protocol Setting the transmission data protocol: 

 Art-Net  ShowNet 

 AVAB/IPX  sACN 

 AVAB/UDP  
 

Light timeout Setting the timeout for receiving data 1 to 999s 

Network send 
rate 

Setting the minimum transmission rate for data packets, if there is no chang-
ing of the values:  20ms, 40ms, 80ms, 100ms, 200ms, 500ms, 1s, 2s, 3s, 4s 

IP Mode Getting the IP address: 

Manual:  Free adjustment 

Art-Net 2:  Art-Net address for 2 network 

Art-Net 10:  Art-Net address for 10 network 

DHCP:   If a DHCP server is on the network 

IP Address IP address   If "IP Mode = Manual" manual adjustment is possible.  

Subnet mask Netmask  If "IP Mode = Manual" manual adjustment is possible. 

GW Gateway  Usually changing the preset address is not necessary. 
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Selection Meaning 

Sendecheck-
summe 

Setting to calculate the checksum of transmitted UDP packets 

On   Enables checksum  

Off   Disabled checksum 

Empfangscheck-
summe 

Setting to calculate the checksum of received UDP packets 

On   Enables checksum 

Off   Disabled checksum 

Set Ethernet me-
dia 

Setting the transmission rate 

Autonegotiation: Enables automatic detection of transmission rate  

Set network  

Parameters:  Set speed and direction parameters manually 

10 Half   Enables 10MBit/s Half Duplex 

10 Full   Enables 10MBit/s Full Duplex 

100 Half  Enables 100MBit/s Half Duplex 

100 Full  Enables 100MBit/s Full Duplex 

Direction control Half Duplex  Enables half duplex 

Full Duplex:  Enables full duplex 

Network Speed 10 MBit  Enables 10MBit/s 

100 MBit  Enables 100MBit/s  

 
 
 
 

Selection Meaning 

Name Setting the Art-Net short name for naming the MasterPort 2 PSU, eg Location "back-
stage" 

sACN 
Draft 

Setting the supported version of sACN 

Off   MasterPort 2 PSU sends sACN according to E1.31 2009 

On   MasterPort 2 PSU sendet sACN according to E1.31 R0 Draft 

Art-Net 
BC 

Art-Net is sent as broadcast. Its necessary for the control of ADB systems. 

Art-
Net3Nw 

Setting the IP address Art-Net3–networks.   

0:   Art-Net3 is disabled. 

1 to 127:  Art-Net3 is active and the number indicates the IP address. 
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Optionen 

In the Options menu you will find first four pages of information about the hardware, software, 
and operating counter about the network. Following basic device settings can be specified. This 
part of this submenu corresponds to the Options menu in the device. 

 

 
 

Selection Meaning 

Menutimeout 
time 

Timeout setting for the return to the First Level, when the encoder is not 
used.  

(OFF, 15s, 30s, 1m, 3m, 5m, 10m, 15m, 20m, 30m, 45m, 1h, 2h, 3h, 4h, 6h, 8h, 
12h, 24h) 

Screensave 
time 

Timeout setting for the screensaver. After the set time the screensaver turns 
off the screen. This measure increases the lifetime of the display siginificantly. 
Inputs by the encoder or by remote control and events turn on the screen.  

(OFF, 15s, 30s, 1m, 3m, 5m, 10m, 15m, 20m, 30m, 45m, 1h, 2h, 3h, 4h, 6h, 8h, 
12h, 24h) 

Default screen Replaces the display First Level by following options: 

Scroll:  “First Level” scrolls through diagnostic pages 

UserTxt: Displaying a user-specified text. When activated, below the line
  a new input mask for text input is displayed. 

BigAdr:  

Display when 
changings 

This submenu corresponds with the submenu Events. Changes to the DMX or 
Ethernet can trigger events, which can be automatically displayed on the 
screen. This can lead to disruptive effects of light. 

On: Changes turn on the screen und will be displayed  

Off: Changes have no effect on the screen 
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Selection Meaning 

Pin PIN for access main menu 

0…30000s (0 = off) 

Send sACN v4 Setting the supported version of sACN 

On MasterPort 2 PSU sends sACN according to E1.31 2009 

Off MasterPort 2 PSU sendet sACN according to E1.31 R0 Draft 

Art-Net3 Net-
work 

Setting the IP address Art-Net3–networks. 

0:  Art-Net3 is disabled. 

1 to 127: Art-Net3 is active and the number indicates the IP address. 

Send Art-Net as 
Broadcast 

Art-Net is sent as broadcast. Its necessary for the control of ADB systems. 

Contrast Setting the contrast 
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PSU 

The submenu PSU corresponds to the device menu Config → PSU. This submenu sets the following 
settings: 
 

 
 
 

Selection Meaning 

Maximum cur-
rent 

Setting of the threshold for the current monitoring. 

Control mode 
PSU 

Setting the switching behaviour 

On:  Service mode! Do not use in normal operation! 

Sense:  The Power-DMX port is automatically switched off when  
  the set current limit or the maximum current of 5A is  
  exceeded. The manual adjustment of the limit is set in the 
  submenu MaxCurr. 

DMX:  Here the DMX address is set. Via this address the   
  Power-DMX port is controlled. Current monitoring is active 
  and corresponds to the settings of "Sense". 

Off:  The Power-DMX port is disabled manually. 

DMX Channel Setting the DMX address for the control of the Power-DMX port. 

 
Never use the switch setting "ON" in continuous operation! This setting is for ser-
vice purposes only! A continuous load of more than 5A may destroy the MasterPort 
2 PSU and the entire lighting system! 

 
Reset the current monitor remotely when a DMX address for the port was set 
Is the Power-DMX port automatically switched off because the set switching 
threshold is exceeded, the port can reset remotly. Providing that a DMX address for 
the port was set, the port must switched off and on again remotly. All settings are 
retained. 
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MasterPort - Groups 

Introduction 

The Master Port Grouping is an elegant way to control several devices simultaneously. Setting 
changes during an event can already be saved in advance as an XML file. This is then used to load 
even more. 
 
 

 If you use this method of setting, make sure that the stored files always represent an 
image of your infrastructure. Devices that have changed you should always be replaced 
in the stored settings (see below).  

 
In addition the MasterPort grouping is also a simple backup/restore method. 
 
 

Creating a new group 

First set all devices on the required settings. Then call up the submenu "Tools" ConfigCore menu 
"MasterPort Groups”. 
 

 
 
Click the button „New Group“.  
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Give your group a meaningful name. On the left side all available MasterPorts are listed. Select the 
desired devices and add them to the group (“>”). 
 

 
 
With the icon ("<") you can deselect unused devices from the group. Green point in front of the 
entries means these devices are accessible and can be programmed. 
 
 

Saving groups 

Is the selection of the group completely, you can save it with the "Save" button. The storage for-
mat is XML. Using an XML editor, you can view the file or change. The file name is "LSS_MP_ 
<Name>. Xml". Like all other XML files, the master port group files are located in the application 
folder of ConfigCore. 
 
 

Loadfing existing group 

Open the submenu “Master Port Groups" in the menu "Tools". Select your group by double-
clicking. 
 
 

Delete group 

Old groups can be deleted with the Del key. These lists have a context menu. In the context menu 
groups can be loaded or deleted too. 
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Changing groups 

Devices that were not found on the network have a red dot. You can replace them by fonded de-
vices. 
 
This means if new devices with the same IP but different MAC address will be used, an error mes-
sage will be displayed. In this case, remove the entry with the red dot from the right list and add 
the new device to the group list. After saving the group is up to date. 
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Default settings 

The factory settings oft he MasterPort 2 PSU: 

 Data protocol:   Art-Net (receiving and transmitting) 

 IP-Mode:   Art-Net 2 network 

 IP address:    According to Art-Net (2.x.y.z) 

 Net mask:   255.0.0.0 

 Gateway:   192.168.172.254 

 Minimum transmission  

rate (Tx rate):   1/s 

 Receiving rate (Rx rate):  8 s 

 Routing DMX-Ports 1…4: subnet 0, universe 0…3 

 Routing DMX-In:  Ethernet transmission ON, priority 0 

 Routing DMX-Out:  Ethernet receiving:  MERGE4 

 DMX-Out behaviour in 

case of data loss:  OFF  

 DMX-Out timing:  Break:  200 µ 

MAB:  20 µ 

 Art-Net short name:   LSS MasterPort 2 PSU 

 Art-Net long name:   MasterPort 2 PSU  (c)2012 LSS GmbH      Version x.xx 

 Screensaver:   15 minutes 

 Events:   OFF 

 Pin request:   OFF 

 Art-Net remote control: ON 
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Service 
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Firmware update 

LSS ConfigCore 

The firmware update of the LSS Master Port 2 PSU must be done with LSS ConfigCore. ConfigCore 
is a freeware and available on the homepage of LSS. ConfigCore only supports Microsoft Windows. 

 

To configure a MasterPort with 2 PSU ConfigCore, two preconditions must be fulfilled: 

 ConfigCore must be installed on a PC 

 The PC and the MasterPort 2 PSU must be in the same range of IP addresses and the same 
subnet 

 

An update can also be done using a LSS FileMaster. On a FileMaster ConfigCore is already prein-
stalled and the server is always in the same subnet as the MasterPort 2 PSUs. 

 

 

Connecting with ConfigCore 

ConfigCore recognizes the MasterPort 2 PSU immediately when both are in the same subnet. 
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Updating firmware 

To initiate the update, select the MasterPort 2 PSU in the device pane. Open the scroll-down menu 
"Extras" and click on "Update Firmware". 

 

 

 
 

This will open the Explorer. 

 

 
 

Firmware updates are provided as alf-files. The name of the file must contain the name of device 
and the version number. Download the file you want. 
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If the file is loaded, a popup with a security request opens. 

 

 

 
 

 

Confirm this request and a second security request followes. In this pop-up shows in addition the 
version numbers of the installed and the update version  
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After confirmation the second request the update will start. A progress bar shows the progression 
of the installation. 

 

 

 
 
 
When the update is done a confirmation of a successfully updating or failure is displayed.  
 

 
 
 
At the end of the update, the control unit of the MasterPort 2 PSU is reset. After reset in Con-
figCore still the old Art-Net device name and the old version number is displayed. That is normal 
until loading the default settings. The device display always shows the current used software ver-
sion. 
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Error messages/failed update 

If the update fails or an error message is displayed, please check the following: 

 

 Did you use the latest version of LSS ConfigCore? If not, please update ConfigCore. 

 Have you updated to the device with the suitable file? 

 

There are still problems please contact the service. 

 
 

Contact 

If problems with the operation of the LSS Master Port 2 PSU occur, the descriptions and infor-
mation in this guide should help for troubleshooting and debugging. If this is not the case and you 
need further assistance, please contact the LSS service. 

 

In contacting you should have available the following information: 

 

 Location of the entire system and position of the MasterPort 2 PSU 

 

 Detailed description of the fault 

 

 Full description of troubleshooting until now 

 

 Description of related system or equipment problems 

 

Contact: 

LSS GmbH 

Licht-, Steuer- und Schaltanlagenbau GmbH 

Am Eichenberg 1 

D-04600 Altenburg 

Phone: +49 3447 835500 

Fax: +49 3447 861779 

mail@lss-lighting.de 
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Appendix A 

Technical specifications 

General technical specifications 

Construction types:   - Built-in device for panel mounting  
  with central or internal power supplies 
- Built-in device for LSS dimmer channels with  
  central power supply 
- Built-in device with case for surface mount with  
  central power supply 

 - Portable with safety bars and internal power supply 
 

Dimensions B x H x T:   Built-in device for panel mounting:  130 x 68 x 155mm 

Built-in device for LSS dimmer:  130 x 68 x 150mm 

Built-in device with case  

for surface mount:    200 x 76 x 155mm 

 Portable with safety bars:  215 x 213 x 175mm 
 

Weight:    Built-in device for panel mounting: 0,65kg 

Built-in device for LSS dimmer: 0,63kg 

Built-in device with case:  2,8kg 

 Portable with safety bars:  4,7kg 
 
EMC standards: EN 55022, class B, FCC part 15, level B 
 
RoHS-directive: Confirm 
 
CPU type: Infineon XE167 
Frequency: 80 MHz 
Cooling: lüfterlos, passiv 
Power supply: 24V DC or IEEE 802.3af 
Screen: Blue text-based with 20x4 symbols & white background light 
 

Power supply PSU:   24V DC  

Operating temperature: 0° - 40°C 
Power consumption: 7- 14W 
 

Interfaces 

Data-DMX: 4x 5pin XLR, female 
Power-DMX: 4x 4pin XLR, female 
Ethernet: RJ-45, 100BaseTx and Power-over-Ethernet (IEEE 802.3af)  
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Network 

DMX 

General 
DMX protocol: DMX-512  
Standards: USITT 1990, DIN 56930-2, ANSI E1.11 
Baud rate: 250 kbps 
Outputs: individually optical-isolated 
 (Isolated according to ANSI E1.11 A1) 
Isolation:     Optocoupler 
Isolation voltage:    1000V DC 

Insulation resistance:    109  
EMC: Filter circuit state of the art at all inputs and outputs 
Termination: Factory internally 
 

Receiving 

Start code: =0    light protocol (in display ●) 

 <>0 no light protocol, RDM (in display  E) 
Minimum protocol length: Start code only 
Maximum protocol length: Startcode + 512 values 
 (More than 512 values will be lost) 

Minimum pass through delay: 44 s 
Maximaum pass through delay: 22,5 ms 
Receiving timeout: 2 s 
Max. distance between two protocols: 2 s 

Minimum realized break: 48 s 
Maximum permissible break: 1,95 s 
 

Transmitting 
Start code: 0 
Protocol length: Startcode + 512 values 
Minimum protocol time: 22,4 ms 
Transmitted protocols per second: 44 
Break length: 90…999 µs (adjustable) 
Mark after Break: 20…999 µs (adjustable) 
Break after Startcode: 25 µs 
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Ethernet 

General 
Interface: 10/100 BaseT (IEEE 802.3u, 802.3x) 
Speed: 10 MBit/s, 100MBit/s; autonegotiation 
Duplex mode: half, full, autonegotiation 
 Auto-MDI/MDIX 
Displaying: Link-LED, Data-LED, speed and duplex mode will be 

displayed in the screen 
Light protocols: Art-Net (ArtisticLicence) 
 AVAB-IPX (AVAB, transtechnik, LDDE,…) 

 AVAB/UDP (transtechnik) 
 ShowNet (Strand Lighting) 

 sACN (ANSI E1.31) 
Further network protocols: ARP, IP, IPX, UDP, IGMPv2 
 

Receiving 
Maximum packet rate: >1000/s (1 light frame/packet) 

Minimum pass through delay: 4 s 
Maximaum pass through delay: 22,7 ms 
Max. distance between two protocols: 1...999 s  (HOLD setable for DMX outs) 
 
 

Transmitting 
Send rate changing of the values: maximum every 20 ms 
Send rate no changing of the values: 20 ms to 4 s (adjustable) 
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Pinouts 

DMX 

5 Pin XLR 

Pinout is according to DMX512 standard. 

 

Pin Description 

1 Ground 

2 Data - 

3 Data + 

4 Spare 

5 Spare  

 

PE can be connected to the cable shielding.  

 
 

4 Pin XLR Power DMX  

Pinout is according to DMX512 standard. 

 

Pin Description 

1 -24V DC 

2 Data - 

3 Data + 

4 +24V DC 

 

PE can be connected to the cable shielding. 
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Ethernet 

Ethernet port supports Power over Ethernet according to IEEE802.3af.  

 

Pin Belegung 

1 Rx + 

2 Rx - 

3 Tx + 

4 V + 

5 V + 

6 Tx - 

7 V - 

8 V - 

S Cable shield 

 
 

Order numbers 

5063:       4x DMX out and 4x DMX-DataPower-Out 


